Unable to create external table in snowflake

Viewed 37

I am trying to create external table in snowflake and it fails with the below error.

SQL compilation error: invalid property 'auto_refresh' for 'different storage type from cloud provider'"

Here are the queries which I am trying.

CREATE OR REPLACE EXTERNAL TABLE DEV_EXT_TABLE WITH LOCATION = @XXX/dev1/metadata/ FILE_FORMAT = (TYPE = PARQUET SKIP_HEADER = 3);

and

CREATE OR REPLACE EXTERNAL TABLE DEV_EXT_TABLE AUTO_REFRESH = TRUE WITH LOCATION = @XXX/dev1/metadata/ FILE_FORMAT = (TYPE = PARQUET SKIP_HEADER = 3);

My account is in AWS whereas stage in Google Cloud Platform and this seems to be supported.

https://docs.snowflake.com/en/user-guide/tables-external-auto.html

Also does snowflake supports Auto refresh or not in cross deployments

1 Answers

Regarding the following: => My account is in AWS whereas the stage is in Google Cloud Platform and this seems to be supported. https://docs.snowflake.com/en/user-guide/tables-external-auto.html

The parameter controlling this feature has not been fully rolled out yet, however, documentation implies that the feature is GA which causes confusion.

Please open a case with Snowflake Support to have the parameter enabled to allow cross cloud auto refresh.

Additionally, SKIP_HEADER is the option for CSV type only not available for PARQUET.

Related