I am trying to deploy a Django application on the azure app service using docker-compose, I already pushed two images to ACR and when I executed the docker-compose.yml on my computer everything worked fine, but when I deploy the app and visit the URL it only shows the next message:
":( Application Error If you are the application administrator, you can access the diagnostic resources."
I also searched in the deployment center logs for any kind of info but there is only this message
"Failed to load container logs: Resource containerlog of type text not found"
any idea how can I fix it?
this is my docker-compose.yml
services:
web:
image: zaito.azurecr.io/backgroundtasks:latest
command: uwsgi --http "0.0.0.0:8000" --protocol uwsgi --module zaitoTasksApi.wsgi --master --processes 4 --threads 2
volumes:
- static_volume:/usr/src/app/static
- media_volume:/usr/src/app/media
expose:
- "8000"
nginx:
image: zaito.azurecr.io/nginx:django
restart: always
volumes:
- static_volume:/usr/src/app/static
- media_volume:/usr/src/app/media
ports:
- "80:80"
depends_on:
- web
volumes:
media_volume:
static_volume: