I am hosting GitLab runner on AWS with docker-machine executor and docker-in-docker for building images, everything was working fine until today, all the pipelines started to fail with "no basic auth credentials" error, the issue is that I am doing ecr authentication and a message also shows that login was successful.
$(aws ecr get-login --no-include-email --region "${REGION}")
WARNING! Using --password via the CLI is insecure. Use --password-stdin.
WARNING! Your password will be stored unencrypted in /root/.docker/config.json.
Configure a credential helper to remove this warning. See
https://docs.docker.com/engine/reference/commandline/login/#credentials-store
Login Succeeded
$ IMAGE_TAG="$CI_COMMIT_SHORT_SHA"
$ echo "Building image..."
Building image...
$ docker build -t $REPOSITORY_URL/"$xxxxxx":latest . -f Dockerfile
Step 1/11 : FROM xxxxxxxx.dkr.ecr.eu-central-1.amazonaws.com/xxxxxxx
Head "https://xxxxxxxx.dkr.ecr.eu-central-1.amazonaws.com/v2/xxxxxxx/manifests/latest": no basic auth credentials
Cleaning up file based variables
00:01
ERROR: Job failed: exit code 1
Has anyone experienced such an issue lately?