control gitlab traffic using haproxy

Viewed 44

We have a gitlab instance that is running in a private subnet in AWS. For some of our projects we need to be able to clone them and execute some pull commands from outside our network. We want to control the acces to this repositories through haproxy and give restricted acces to them. We are cloning them through https, so we do not need ssh trafic forward for them. The problem is that i have setup the rules to fwd the request for a specific repository to gitlab but every time i try to login i get : remote: HTTP Basic: Access denied fatal: Authentication failed for ...

The rule is something simple like :

use_backend gitlab if { path_beg /path1/path2/repo.git } 

Our backend definition looks like :

backend gitlab
    mode http
    server gitlab git.internal.server:80

Anyone managed to this thing using haproxy ?

0 Answers
Related