Pod restart alone and lose data Minikube k8s

Viewed 30

i deployed hdfs into minikube using helm chart, i also using minikube multinodes(3nodes), after the deploying of hdfs, everytime i run minikube start the pods restart everything from 0 ( i lose the data that i put it on hdfs),meanwhile i tried to apply a pvc :

persistence:
  nameNode:
    enabled: true
    storageClass: standard-ssd
    accessMode: ReadWriteOnce
    size: 50Gi
  dataNode:
    enabled: true
    storageClass: standard-hdd
    accessMode: ReadWriteOnce
    size: 200Gi

but i get this error : Error validatin data :[apiVersion not set, kind not set]if you choose to ignore these errors, turn validation offset How can i solve this problem ?

0 Answers
Related