Context: I am working in Kibana. It is hooked up to an elastic cluster running in docker.
Here is the objective:
- I currently have an index pattern named
objects-*that matches on several indices of the formobjects-name,objects-pattern, etc. - I have created several visualizations that use this index pattern and I don't want these visualizations to begin erroring and become unusable (this tends to happen when I mess with indices or patterns)
- Shortly, the indices described are going to be deleted and the same data is going to be put in to indices of the form
objects-sco-name,objects-sco-pattern, etc. Essentially the charactersscoand going to be added to the index names. - Note that these new indices should still match the existing index pattern
objects-*
Will the existing index pattern be affected by the actions described? Will my Kibana visualizations be affected?
Thank you