jenkins docker slave inbound connection with self signed certificate

Viewed 53

We move our Jenkins to use a self-signed certificate and then docker slaves (inbound, image: jenkins-inbound-agent) strat to fail to connect as the certificate is not trusted. We try to add -cert @<path to file> and we get an error empty input (we check the file and it is OK) Second, we tried to add the certificate as env but then it complained about an unknown option -----END CERTIFICATE-----

What can be done?

0 Answers
Related