mariadb 10.5 server: ERROR 1356 (HY000): View 'mysql.user' references invalid table(s)

Viewed 288

I've a newly installed debian 11.1 with mariadb-server-10.5 (1:10.5.15-0+deb11u1) where I created a new user and dropped it:

#something like that:
create user 'testuser1'@'localhost' identified by 'pw';
use mysql;
delete from user where name = 'testuser1'

. After flushing privileges I got this error:

MariaDB [mysql]> select * from user;
ERROR 1356 (HY000): View 'mysql.user' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them

, and I seem to get no way to fix it.

I know I should have used drop user, but it's too late.

Could anyone suggest me a solution to solve this?


I'm pretty sure the definition of the view has not been changed.

1 Answers

The problem is that this line:

delete from user where name = 'testuser1';

shoud've send an error as output, because there is no column in mysql.user thats called 'name'.

Related