I have deployed a Flask application and its containers in an AWS EKS managed Kubernetes cluster, and the cluster's security group is IP whitelist secured.
I created the cluster using eksctl, created an RDS instance for it, and deployed the application using it's helm chart.
I am trying to access the APIs of the flask application from within a AWS Sagemaker Notebook instance, but because of the IP whitelist, I am unable to connect. The connection times-out instead.
Can anyone tell me how I can add the Notebook instance to my whitelist?