When starting the images alpine and ubuntu, podman works. If starting the images ubi8 and grafana/grafana-oss, it fails with
Error: writing blob: adding layer with blob "sha256:de63ba066b7c0c23e2434efebcda7800d50d60f33803af9c500f75a69fb76ffa": Error processing tar file(exit status 1): operation not supported
Why is it failing with some images but not others? This is being done rootless, but a network file system is not in play. Full output:
$ whoami
foo
$ echo $HOME
/home/foo
$ df -h /home
Filesystem Size Used Avail Use% Mounted on
rootfs 7.9G 6.8G 1.2G 86% /
$ podman run -it ubi8
Resolved "ubi8" as an alias (/etc/containers/registries.conf.d/001-rhel-shortnames.conf)
Trying to pull registry.access.redhat.com/ubi8:latest...
Getting image source signatures
Checking if image destination supports signatures
Copying blob 1b890c73c3cf skipped: already exists
Copying blob de63ba066b7c done
Error: writing blob: adding layer with blob "sha256:de63ba066b7c0c23e2434efebcda7800d50d60f33803af9c500f75a69fb76ffa": Error processing tar file(exit status 1): operation not supported
It looks similar to but is not the error given when trying to store data on a network file system. ($HOME is a local fs.) The host system is an OS image running in memory on a VMware VM. The OS is RHEL8.6. Kernel=4.18.0.