I am having troubles to configure the rules of a load balancer. I already have rules based on the path of the request and they work just fine. I would like to add a security layer and filter the incomming requests with the domain's name, the goal is to allow a list of domains that can access the load balancer, and to return a 404 error otherwise.
I have looked at this documentation : https://aws.amazon.com/fr/blogs/aws/new-host-based-routing-support-for-aws-application-load-balancers/
It is pretty straight forward but it doesn't work in my case and I can't figure it out...
Here is a screenshot of my rules configuration :

When I try this request test.domain-name.com/test in postman, it returns a 404 error like expected, but with the right domain it also returns a 404.
I edited the rule with *.domain-name.com and it works with the domain name but the request is also working in postman, which is not the expected behavior.
Does anyone have the same problem ? Did I miss something ?
Thanks,