This error occurs when you are requesting aggregated data using the URL:
POST - {{DIMENSIONSHOST}}/v1/commons/data/multi_read
The Postman body that I used was:
{
"select": [
{"key": "EMP_COMMON_FULL_NAME"}
],
"from": {
"view": "EMP",
"employeeSet": {
"hyperfind": {
"id": -9
},
"dateRange": {
"startDate": "2022-01-01",
"endDate": "2022-04-30"
}
}
},
"index": 0,
"count": 500
}
Notice that I requested "count": 500. Even though I requested only 500 records, I got the error message that there were more than 500 records.