Currently I have a .NET Core 6.0 application running on an Amazon Linux EC2 instance deployed through Elastic Beanstalk. My web.stdout logs indicate that it's not able to write to the file system.
web: Unhandled exception. System.UnauthorizedAccessException: Access to the path '/Settings/SharedSettings/' is denied.
I have an EBS volume mounted to the root directory of the EC2 instance and running the command 'mount' indicates that I should have read/write permissions for it.
/dev/xvda1 on / type xfs (rw,noatime,attr2,inode64,noquota)
What am I missing here? I have a very limited understanding of both AWS and Linux so if anyone can point me to where I'm messing up I'd appreciate it.