Databricks and Azure Blob Storage

Viewed 220

I am running this on databricks notebook

dbutils.fs.ls("/mount/valuable_folder")

I am getting this error

Caused by: StorageException: Server failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature.

I tried using dbutils.fs.refreshMounts()

to get any updates in azure blob storage, but still getting above error.

1 Answers

Such errors most often arise when credentials that you have used for mounting are expired - for example, SAS is expired, storage key is rotated, or service principal secret is expired. You need to unmount the storage using dbutils.fs.unmount and mount it again with dbutils.fs.mount. dbutils.fs.refreshMounts() just refreshes a list of mounts in the backend, it doesn't recheck for credentials.

Related