We created an Azure VM with a user-assigned managed identity as described here.
The following environment variable was exported, so the Azure CLI uses a proxy (direct internet connection is blocked in our subnet).
export http_proxy="http://proxy.local:111"
export https_proxy="http://proxy.local:111"
Now I would like to use az login --idenity to login to Azure with the assigned managed identity.
Unfortunately, I receive all the time the following message:
Failed to connect to MSI. Please make sure MSI is configured correctly.
Get Token request returned http error: 400, reason: Bad Request