Why Does Phpmyadmin Suddenly Not Load

Viewed 3736

Just upgraded to Ubuntu 22.04 and now my phpadmin won't load. I get this following error

Parse error: syntax error, unexpected 'static' (T_STATIC) in /usr/share/php/Symfony/Component/DependencyInjection/ContainerBuilder.php on line 272

I opened up the file, and here is the specific code in that segment.

public function addResource(ResourceInterface $resource): static
{
    if (!$this->trackResources) {
        return $this;
    }

   if ($resource instanceof GlobResource && $this->inVendors($resource->getPrefix())) {
       return $this;
    }

    $this->resources[(string) $resource] = $resource;

   return $this;
}

Yesterday before the upgrade, everything was working fine. Does anybody have any suggestions?

4 Answers

Since version 8.0, PHP allows static as a return type for class methods. Apparently your PHP version was downgraded.

Yes, it's a pain if you are running a PHP version prior to 8, such as 7.*. Download 5.2 here and install it.

https://www.phpmyadmin.net/downloads/

Completely purge your previous version and secure the directory where you install it (depends on your web server). That Symfony component ruined everything (line 272).

You have to check your phpmyadmin version Coz in php 8.* version phpmyadmin 5.* version will be required.

Related