Docker Engine Fails to start on Windows Server 2019

Viewed 170

Our application is docker based and requires Nat network to be created on the host machine in order to communicate since its a web service. It was working since last 4 months and suddenly stopped working. Checked and found that docker service is stopped. Manually tried restarting the service but it failed to start. Below is the error in the event log:

Error:

fatal: failed to start deamon: Error initializing network controller: Error creating default network: failed during hnsCallRawResponse: hnsCall failed in Win32: There are no more endpoints available from endpoint mapper. (0x6d9)

Tried the below steps:

  1. Deleted the hns.data and restarted the hns service. Then restarted the docker engine service. The issue persists.

  2. Tried running MOFCOMP. Same issue.

  3. Tried removing docker and reinstalling it. Doesn't work.

  4. Tried creating nat network manually. But getting the above mentioned error.

Can someone help here? what needs to be checked or what could be the reason for this issue?

0 Answers
Related