Quarkus logger does not replace %s in log

Viewed 126

I'm trying to deploy a Quarkus app. However, there is some broken log from some of the dependencies I'm using when building/running it. No clear explanation where to look. Placeholders (%s and all it's variants) do not show any data, only the template itself.

The project is based on a very similar one which works just fine.

Here is part of the log:

exec java -Dquarkus.http.host=0.0.0.0 -Djava.util.logging.manager=org.jboss.logmanager.LogManager -XX:+ExitOnOutOfMemoryError -cp . -jar /deployments/quarkus-run.jar
Mar 18, 2022 11:47:54 PM org.hibernate.Version
INFO: HHH000412: Hibernate ORM core version %s
Mar 18, 2022 11:47:54 PM org.hibernate.annotations.common.Version
INFO: HCANN000001: Hibernate Commons Annotations {%1$s}
Mar 18, 2022 11:47:55 PM org.hibernate.dialect.Dialect
INFO: HHH000400: Using dialect: %s
Mar 18, 2022 11:47:55 PM io.quarkus.arc.impl
WARN:
%1$s%1$s%1$s%1$s
CDI: programmatic lookup problem detected
-----------------------------------------
At least one bean matched the required type and qualifiers but was marked as unused and removed during build
Removed beans:
- %2$s
Required type: %3$s
Required qualifiers: %4$s
Solutions:
- Application developers can eliminate false positives via the @Unremovable annotation
- Extensions can eliminate false positives via build items, e.g. using the UnremovableBeanBuildItem
- See also https://quarkus.io/guides/cdi-reference#remove_unused_beans
%1$s%1$s%1$s%1$s
One or more configuration errors have prevented the application from starting. The errors are:
- SRCFG00011: Could not expand value nameOfProperty1 in property quarkus.datasource.username
- SRCFG00011: Could not expand value nameOfProperty2 in property quarkus.datasource.password

There is a similar question (similar output) but not sure the root cause is the same.

  • Quarkus version: 1.13.7.Final
  • Compiler plugin: 3.8.1
  • Java: 11
1 Answers

The issue seemed to be a resource file placed in a wrong location.

The file org.eclipse.microprofile.config.spi.ConfigSource was placed in src\main\resources\services instead of src\main\resources\META-INF\services.

Related