Error on pg_logical_slot_peek_changes: client sent proto_version=0 but we only support protocol 1 or higher

Viewed 376

I'm trying to call the function pg_logical_slot_peek_changes with PostgreSQL 13 on a replication slot, but I always get the following error:

ERROR:  client sent proto_version=0 but we only support protocol 1 or higher
CONTEXT:  slot "test_slot", output plugin "pgoutput", in the startup callback

I've tried executing the command in different clients: PgAdmin, Psql, Dbeaver, but they all return the same error.

What am I missing?

1 Answers

That function only works with 'test_decoding' plugin, which is not the one you are using.

Related