ERROR: services.db Additional property volume is not allowed

Viewed 1340

#solved there a typo on volume , it must be volumes

i want to ask a question, i already created the Dockerfile and also docker-compose.yaml in my laravel tutor project, and i faced this problem after wrote all the code in the docker-compose.yaml in the terminal

im running docker-compose up in the terminal and it shows the services.db Additional property volume is not allowed. what should i do to solve this error. i am sorry this is my first time using docker.

version: "3.7"
services:
  frontend:
    image: antoniopapa1991/admin-frontend
    depends_on:
      - backend
    networks:
      - app

  backend:
    container_name: admin_api
    build:
      context: .
      dockerfile: Dockerfile
    environment:
      DB_HOST: db
      DB_DATABASE: admin
      DB_USERNAME: root
      DB_PASSWORDK: root
    ports:
      - 8000:8000
    volumes:
      - .:/app
    depends_on:
      - db
    networks:
      - app

  db:
    container_name: admin_db
    image: mysql:5.7.22
    environment:
      MYSQL_DATABASE: admin
      MYSQL_USER: root
      MYSQL_PASSWORD: root
      MYSQL_ROOT_PASSWORD: root
    volume:
      - .dbdata:/var/lib/mysql
    ports:
      - 33066:3306
    networks:
      - app

networks:
  app:
1 Answers

Fix it volume: on volumes: Should work

Related