I'm having some trouble in seeing why a helm upgrade command is failing after the first run in a pipeline. On subsequent runs the command fails, and not much is shown in the verbosity of logs. Errors i'm getting relate to "Script execution interrupted" I think it's due to the upgrade command running again after the initial run. I tried using force flag to force a run, and the upgrade command will fail. How can i go about to resolving this?
helm repo add newrelic https://helm-charts.newrelic.com
helm upgrade --debug --force --install newrelic newrelic/nri-bundle \
--namespace newrelic --create-namespace \
--set global.licenseKey=$licensekey \
--set global.cluster=$my_lucster \
--set ksm.enabled=true \
--set newrelic-infrastructure.privileged=true \
--set infrastructure.enabled=true \
--set prometheus.enabled=true \
--set webhook.enabled=true \
--set kubeEvents.enabled=true \
--set logging.enabled=true