I was trying to connect my ubuntu device to aws ec2 instance using a pem file, but while performing the ssh -i file.pem user@ipadress a bad configuration error called ServerAliveInternal happened (not ServerAliveInterval). I solved it by purging the openssh and reinstalling it, however I was wondering what might have happened? I searched here but did not find anything about it.