I have created a virtual machine using RedHat OpenShift virtualization, but I am unable to connect to it using SSH.
My virtual machine pod is running and I am able to able to access the pod terminal from the webconsole. I followed the instructions given in this page to create the ssh service.
[root@api.ocpcluster-m1.cp.mydomain.com ~]# oc get pods
NAME READY STATUS RESTARTS AGE
virt-launcher-fedora-clumsy-lamprey1-7rdgm 1/1 Running 0 22d
[root@api.ocpcluster-m1.cp.mydomain.com ~]# oc get svc
NAME TYPE CLUSTER-IP EXTERNAL-IP PORT(S) AGE
fedora-vm-ssh NodePort 172.30.84.81 <none> 22:31016/TCP 22d
[root@api.ocpcluster-m1.cp.mydomain.com ~]# ssh root@10.17.55.207 -p 31016
ssh: connect to host 10.17.55.207 port 31016: No route to host
[root@api.ocpcluster-m1.cp.mydomain.com ~]#
10.17.55.207 is the IP of one of the nodes.
What am I doing wrong here?