Microsoft Access DBEngine.OpenDatabase() breaks for Network-Paths - Error 3050

Viewed 5176

We have an Access Database-Solution with Frontend and Backend Database running for years.

Now within the last two days problems occurred. E.g.

        Set db = DBEngine.OpenDatabase(strDatabasePath, False, True, "MS Access;PWD=" & strPassword)

Does result in Error 3050 - File could not be locked. ONLY when the Backend Database is on a network share (if it's on a local drive everything works as expected).

The error occurs on any share:

  • a Shared Folder from a Windows PC
  • a Shared (Samba) Folder on a NAS
  • independently whether the share is accessed via a UNC-Path (\server\share) or a mapped drive-path.

The error was introduced by a faulty Office Patch (seems it was V2111 - 14701.20240)

In the first version of this post I thought that Windows-Update KB5008212 was causing the problem.

Thanks to @Gustav for identifying the problem.

How do we find out WHEN MS pleases to fix the problem?

4 Answers

From Microsoft:

This is due to today’s (Patch Tuesday) update to Office. The problem was introduced by a security fix, so it impacts all active versions of Access. We are working on a fix, and will deliver it as quickly as possible.

The update has only been set to automatically update a very small percentage of users, and it looks like we will be able to pause automatic updates, so it will not propagate.

There will be a page added to the

Fixes or workarounds for recent issues in Access (microsoft.com),

which will then be the place to go for updates.

These are the updates that introduced the problem:

KB 5002104 for Office 2013
KB 5002099 for Office 2016
Office 2019 Version 1808, build 10381.20020
Office LTSC 2021 Version 2108, build 14332.20204
Microsoft 365 Apps:
    Current Channel Version 2111, build 14701.20248
    Monthly Enterprise Channel Version 2110, build 14527.20340
    Monthly Enterprise Channel Version 2109, build 14430.20380
    Semi-Annual Enterprise Channel (Preview) Version 2108, build 14326.20692
    Semi-Annual Enterprise Channel Version 2102, build 13801.21086
    Semi-Annual Enterprise Channel Version 2008, build 13127.21842

If you did get updated to one of those builds, the only solution currently is to move back to an earlier build in the channel.

We had the same problems.

Uninstalling Office 365 (32-bits) and re-installing Office 365 (32-bits) from the OfficeWeb-Portal seems to solve the problem.

Installing version 2008, in fact, resolved the issue for me. Microsoft just released new builds of versions 2108 and 2112 yesterday, 01/11/2022, that also resolved this same issue for me.

Ours is not manifesting in the same way. I seem to get a lot of orphaned lock files. Users are having some problems getting in to the databases but usually If I delete the lock file and have them wait 5 minutes, the problem goes away. Since this started it has been a game of running daily backups to a separate file just in case. Major Pain in the you know what. I'll keep an eye on what crops up here. Thanks folks (Yes this is more of a comment than an Answer, but I needed more characters)

Related