UPTADE: According to what our system expert told me, they fixed the problem as follows: v6 ips must be disabled in the operating systems they are in.
I have a python file on the server that is scheduled to run every week. like this:
from google.cloud import bigquery
gbq_credentials = create_gc_credentials(settings)
client = bigquery.Client(credentials=gbq_credentials,project=project_id)
df = client.query(sql_query).to_dataframe()
#data processing
....
But the file that works every week, gave an error today:
Error 403 (Forbidden)!!1
Your client does not have permission to get URL <code>/bigquery/v2/projects/xxxx/jobs</code> from this server.
when I run the same file on my local computer, I didn't get any errors.
I updated the outdated python libraries on the server. But it didn't work. Also I get the same error on all files using the google cloud module.
What could this problem be caused by ?