Nextcloud with Replicas on Azure Kubernetes - Failing to Mount Azure Files ReadWriteMany Volume

Viewed 263

I'm trying to deploy Nextcloud w/HPA (replicas - horizontal scaling) on Azure Kubernetes with the official Nextcloud Helm chart and a ReadWriteMany volume created following these official instructions, but the volume never mounts, get this (or some version thereof) error:

kind: Event
apiVersion: v1
metadata:
  name: nextcloud-6bc9b947bf-z6rlh.16bf7711bc2827a5
  namespace: nextcloud
  uid: c3c5619b-19da-4070-afbb-24bce111ddbe
  resourceVersion: '55858'
  creationTimestamp: '2021-12-10T18:08:27Z'
  managedFields:
    - manager: kubelet
      operation: Update
      apiVersion: v1
      time: '2021-12-10T18:08:27Z'
      fieldsType: FieldsV1
      fieldsV1:
        f:count: {}
        f:firstTimestamp: {}
        f:involvedObject: {}
        f:lastTimestamp: {}
        f:message: {}
        f:reason: {}
        f:source:
          f:component: {}
          f:host: {}
        f:type: {}
involvedObject:
  kind: Pod
  namespace: nextcloud
  name: nextcloud-6bc9b947bf-z6rlh
  uid: 6106d13f-7033-4a4e-a6e9-a8e3947c52a4
  apiVersion: v1
  resourceVersion: '55764'
reason: FailedMount
message: >
  MountVolume.MountDevice failed for volume "nextcloud-rwx" : rpc error: code =
  Internal desc = volume(#azure-secret#aksshare#) mount
  "//nextcloudcluster.file.core.windows.net/aksshare" on
  "/var/lib/kubelet/plugins/kubernetes.io/csi/pv/nextcloud-rwx/globalmount"
  failed with mount failed: exit status 32

  Mounting command: mount

  Mounting arguments: -t cifs -o
  dir_mode=0777,file_mode=0777,gid=33,mfsymlinks,actimeo=30,<masked>
  //nextcloudcluster.file.core.windows.net/aksshare
  /var/lib/kubelet/plugins/kubernetes.io/csi/pv/nextcloud-rwx/globalmount

  Output: mount error(13): Permission denied

  Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log
  messages (dmesg)
source:
  component: kubelet
  host: aks-agentpool-16596208-vmss000002
firstTimestamp: '2021-12-10T18:08:27Z'
lastTimestamp: '2021-12-10T18:08:35Z'
count: 5
type: Warning
eventTime: null
reportingComponent: ''
reportingInstance: ''

Here is my PersistentVolume yaml:

apiVersion: v1
kind: PersistentVolume
metadata:
  name: nextcloud-rwx
  namespace: nextcloud
spec:
  capacity:
    storage: 32Gi
  accessModes:
    - ReadWriteMany
  azureFile:
    secretName: azure-secret
    shareName: aksshare
    readOnly: false
  mountOptions:
  - dir_mode=0777
  - file_mode=0777
  - gid=33
  - mfsymlinks

PersistentVolumeClaim yaml:

apiVersion: v1
kind: PersistentVolumeClaim
metadata:
  name: nextcloud-rwx
  namespace: nextcloud
spec:
  accessModes:
    - ReadWriteMany
  storageClassName: ""
  resources:
    requests:
      storage: 32Gi

I've also tried changing uid and gid to 0, 1000, etc, and get an even more egregious permission denied message because it doesn't "match the fsgroup(33)" (hence why I tried with gid=33).

Any ideas would be greatly appreciated! Thank you for your time.

0 Answers
Related