I have a web scraping app that is deployed on a kubernetes cluster on GCP and this app uses a proxy to connect to multiple browsers. So I need to assign a static ip address so that the proxy can do its job, but the problem here is that I can't figure out which address to give to the proxy server. I tried to give the ingress and egress static address but it always shows "Connection refused with the proxy" error.
PS: The proxy works like magic on my local machine as I'm using a dns server to fix the dynamic IP addresses situation.
How should I do the same when the environment is actually on GKE.
