Rstudio server rocker image memory limit file not found

Viewed 90

I'm using the latest docker image of rocker r_studio server on an HPC environment. Here is a link of this image.

The problem is that whenever I launch Rstudio on my server I get some sort of file missing that is related to memory:

2021-11-12T02:12:02.914355Z [rsession-alexandre] ERROR The previous R session terminated abnormally; LOGGED FROM: rstudio::core::Error {anonymous}::rInit(const rstudio::r::session::RInitInfo&) src/cpp/session/SessionMain.cpp:694 2021-11-12T02:12:03.440178Z [rsession-alexandre] ERROR system error 2 (No such file or directory) [path: /sys/fs/cgroup/memory/memory.limit_in_bytes]; OCCURRED AT rstudio::core::Error rstudio::core::FilePath::openForRead(std::shared_ptrstd::basic_istream<char >&) const src/cpp/shared_core/FilePath.cpp:1453; LOGGED FROM: rstudio_boost::shared_ptrrstudio::core::system::{anonymous}::LinuxMemoryProvider rstudio::core::system::{anonymous}::getMemoryProvider() src/cpp/core/system/LinuxResources.cpp:374

Could anyone guide me on reasons why this error is arising ? Any feedback is highly appreciated, thanks

1 Answers

take a look to the actual logs tail /var/log/rstudio/rstudio-server/rserver.log 2022-06-20T10:31:37.673045Z [rserver] WARNING Jupyter sessions may only be used with the Job Launcher. Disabling Jupyter integration; LOGGED FROM: rstudio::core::ProgramStatus rstudio::server::jupyter::Options::read() src/cpp/server/jupyter/JupyterOptions.cpp:127

Related