bitnami parse server with docker-compose give blank screen after dashboard login

Viewed 269

I'm trying to run bitnami parse-server docker images with docker-compose configuration created by bitnami (link) locally (for testing)

i run the code provided on their page with ubuntu 20.04

$ curl -sSL https://raw.githubusercontent.com/bitnami/bitnami-docker-parse/master/docker-compose.yml > docker-compose.yml
$ docker-compose up -d

the dashboard run fine from the browser on http://localhost/login, but after entering the user and pass the browser start loading then ends up with blank white screen.

cosole errors

cosole errors

here's the docker-compose code

version: '2'
services:
  mongodb:
    image: docker.io/bitnami/mongodb:4.2
    volumes:
      - 'mongodb_data:/bitnami/mongodb'
    environment:
      - ALLOW_EMPTY_PASSWORD=yes
      - MONGODB_USERNAME=bn_parse
      - MONGODB_DATABASE=bitnami_parse
      - MONGODB_PASSWORD=bitnami123
  parse:
    image: docker.io/bitnami/parse:4
    ports:
      - '1337:1337'
    volumes:
      - 'parse_data:/bitnami/parse'
    depends_on:
      - mongodb
    environment:
      - PARSE_DATABASE_HOST=mongodb
      - PARSE_DATABASE_PORT_NUMBER=27017
      - PARSE_DATABASE_USER=bn_parse
      - PARSE_DATABASE_NAME=bitnami_parse
      - PARSE_DATABASE_PASSWORD=bitnami123
  parse-dashboard:
    image: docker.io/bitnami/parse-dashboard:3
    ports:
      - '80:4040'
    volumes:
      - 'parse_dashboard_data:/bitnami'
    depends_on:
      - parse
volumes:
  mongodb_data:
    driver: local
  parse_data:
    driver: local
  parse_dashboard_data:
    driver: local

What am i missing here ?

1 Answers

The parse-dashboard knows the parse backend through its docker-compose hostname parse.

So after login, the parse-dashboard (UI), will generate requests to that host http://parse:1337/parse/serverInfo based on the default parse backend hostname. More details about this here.

The problem is that your browser (host computer) doesn't know how to resolve the ip for the hostname parse. Hence the name resolution errors.

As a workaround, you can add an entry to your hosts file to have the parse hostname resolved to 127.0.0.1.

This post describes it well: Linked docker-compose containers making http requests

Related