Error: action failed after 10 attempts: failed to connect to the management cluster. Get https://127.0.0.1:43343/api?timeout=30s: EOF

Viewed 97

I am creating an EKS-Anywhere local cluster by following these steps: Create local cluster | EKS Anywhere

Getting the following error after executing this command.

eksctl anywhere create cluster -f $CLUSTER_NAME.yaml

Performing setup and validations
Warning: The docker infrastructure provider is meant for local development and testing only
✅ Docker Provider setup is valid
Creating new bootstrap cluster
Installing cluster-api providers on bootstrap cluster
Provider specific setup
Creating new workload cluster
Installing networking on workload cluster
Installing storage class on workload cluster
Installing cluster-api providers on workload cluster
Moving cluster management from bootstrap to workload cluster
Error: failed to create cluster: error moving CAPI management from source to target: failed moving management cluster: Performing move...
Discovering Cluster API objects
Moving Cluster API objects Clusters=1
Creating objects in the target cluster
Deleting objects from the source cluster
Error: action failed after 10 attempts: failed to connect to the management cluster: action failed after 9 attempts: Get https://127.0.0.1:43343/api?timeout=30s: EOF


2 Answers

It could be a resource constraint on your docker deployment. How much RAM and disk is Docker configured with. I have something like 16gb RAM and 60 gig disk which is more than required, but it does work.

Related