can't start mariaDB on manjaro

Viewed 1457

I'm trying to start phpmyadmin, but i can't seem to start mariadb first. here is the command i'm trying to do :
systemctl start mariadb

Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xeu mariadb.service" for details.

other commands :
journalctl -xeu mariadb.service

Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] InnoDB: 10.6.4 started; log sequence number 33110; transaction id 4
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [ERROR] Could not open mysql.plugin table: "Table 'mysql.plugin' doesn't exist". Some plugins may be not loaded
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] InnoDB: Buffer pool(s) load completed at 210930  9:00:45
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] Server socket created on IP: '0.0.0.0'.
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [Note] Server socket created on IP: '::'.
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.db' doesn't exist
Sep 30 09:00:45 vincent mariadbd[5314]: 2021-09-30  9:00:45 0 [ERROR] Aborting
Sep 30 09:00:46 vincent mariadbd[5314]: Warning: Memory not freed: 280
Sep 30 09:00:46 vincent systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE

pacman -Qs mariadb

local/mariadb 10.6.4-1
    Fast SQL database server, derived from MySQL
local/mariadb-clients 10.6.4-1
    MariaDB client tools
local/mariadb-libs 10.6.4-1
    MariaDB libraries

I can't seem to understand what's wrong, is it because "mysql.db" doesn't exist ? if yes, how can i create it ?

All the best

2 Answers

Can i suggest you to use dockerised versions and link them in docker-compose environment , your file will be like this:

version: '3'
 
services:
  db:
    image: mariadb:10.6.4
    container_name: db
    environment:
      MARIADB_ROOT_PASSWORD: my_secret_password
      MARIADB_DATABASE: app_db
      MARIADB_USER: db_user
      MARIADB_PASSWORD: db_user_pass
    ports:
      - "6033:3306"
    volumes:
      - dbdata:/var/lib/mysql
  phpmyadmin:
    image: phpmyadmin/phpmyadmin
    container_name: pma
    links:
      - db
    environment:
      PMA_HOST: db
      PMA_PORT: 3306
      PMA_ARBITRARY: 1
    restart: always
    ports:
      - 8081:80
volumes:
  dbdata:

mariadb-install-db --user mysql will install into that directory. Its unclear why its blank. Usually the package manager pacman would of done this already.

Related