"The requested URL was not found on this server" after TYPO3 installation

Viewed 432

After I have installed TYPO3 on my local host this error occurs

The requested URL was not found on this server

I can show the login page of admin. After entering the credentials then occurs this error.

3 Answers

As written by Julian you need to make sure that there is the correct .htaccess file in your document root directory.

If the file is missing, you can find a sample file here:
/typo3/sysext/install/Resources/Private/FolderStructureTemplateFiles/root-htaccess

sometimes deleting .htaccess was the solution. (typo3 Install-Tool Environment offers to try repairing it. ) Rename your .htaccess, so you are able to compare differences later

This happens when upgrading from typo3 v10 to v11. The typo3v10 .htaccess is still used, and it does not have rewrites for /typo3/.

Remove the public/.htaccess file and run the install tool in /typo3/install.php and let the "Directory status" tool re-create it.

Related