I just started to use the Kusto query language. Still trying to grasp all of it.
So I have a query to get some SignIn events with a timestamp. But I'm only interested in the unique values with the most recent date.
Distinct is not an option because all rows are different due to this timestamp. Also the query returns too many results so it can't be processed.
Query to get all the logs is:
SigninLogs
| project TimeGenerated, Identity, UserPrincipalName, Location, DeviceDetail