kubelet won't start on Ubuntu: misconfiguration: kubelet cgroup driver: \"systemd\" is different from docker cgroup driver: \"cgroupfs\"

Viewed 1180

I've seen this error reported for CentOS, but not for Ubuntu 18. I'm using the same script that I've used for months to setup a k8s master node, but now it's failing with

misconfiguration: kubelet cgroup driver: \"systemd\" is different from docker cgroup driver: \"cgroupfs\"

This is not minikube.

Is think this is coming from kubeadm init.... Is there an option I can set to fix this?

0 Answers
Related