Locally, my api is working fine but in the Azure apim when i add these lines in the controller (to access my RavenDB) i get an internal server error 500.
Here is the startup configuration:
i'm also using AzureKeyVault to get the certificate to access my RavenDB.
I added the apim's IP in the allowed IPs of RavenDB Cloud, without success.
The question is, how can i fix that ?
Feel free to ask in case you need more informations.
EDIT
I recently had more information about the error 500

Problem solved Waiting for @TinyWang to write his anwser instead of a comment. You can find the things that worked for me in the comments.



