I am trying to update a docker image that uses python:3.9 as base (which uses Debian GNU/Linux 10 (buster)), but it now fails with steps that before gave no problems.
The new image sha is @sha256:8f642902ba368481c9aca0a100f08daf93793c6fa14d3002253ea3cd210383a7, and the commands I use can be found in here https://docs.microsoft.com/en-us/sql/connect/odbc/linux-mac/installing-the-microsoft-odbc-driver-for-sql-server?view=sql-server-ver15#debian17.
Here it comes the output error:
#20 0.380 Reading package lists...
#20 0.838 Building dependency tree...
#20 0.942 Reading state information...
#20 0.998 Some packages could not be installed. This may mean that you have
#20 0.998 requested an impossible situation or if you are using the unstable
#20 0.998 distribution that some required packages have not yet been created
#20 0.998 or been moved out of Incoming.
#20 0.998 The following information may help to resolve the situation:
#20 0.998
#20 0.998 The following packages have unmet dependencies:
#20 1.049 libodbc1 : PreDepends: multiarch-support but it is not installable
#20 1.049 odbcinst1debian2 : PreDepends: multiarch-support but it is not installable
#20 1.062 E: Unable to correct problems, you have held broken packages.
------
executor failed running [/bin/sh -c ACCEPT_EULA=Y apt-get install -y msodbcsql17]: exit code: 100
does anyone have an idea why did it stop to work with the new image release?