I want to setup Keycloak for my Pipeline, this should be done automatically, I thought of manually pre configuring an realm in the webinterface of keycloak and then exporting this realm using this page: exporting page on keycloak image
then i want to import it at every run of the pipeline so I get a fresh environment.
For importing my realm I used this endpoint:
http://localhost:8080/auth/admin/realms
when executing in postman, I get this error
"error": "unknown_error"
and in the console it says
Script upload is disabled
It looks like script uploads could be activated but according to the documentation docu profiles this feature is marked as deprecated. So I think this option would not be the way to go and future proof?
Maybe there is even another option that would be better for my usecase?
I am using Keycloak in a Docker Container quay.io/keycloak/keycloak - with the latest version currently version 15.0.1 of keycloak
Thank you for your time to answer the question.