when I try to use a sharding MongoDB cluster to save data from kafka ,it raise an error like
'com.mongodb.MongoBulkWriteException: Bulk write operation error on server 192.168.50.117:20000. Write errors: [BulkWriteError{index=0, code=61, message='Failed to target upsert by query :: could not extract exact shard key', details={}}]'
kafka:v2.7,
mongodb:v 4.2,
connector type: distributed,
I have tried to reset the sharding config and restart kafka server/connector server ,but it does not work
Thanks!