Magento 2.4.2 invalid header value detected in laminas-http module GenericHeader.php

Viewed 901

I installed Magento 2.4.2 on XAMPP server on my localhost by

  1. downloading using Composer and
  2. running php bin/magento setup:install
  3. after the installation I run php bin/magento setup:static-content:deploy -f
    Now when I try to run Magento from localhost/magento242/pub directory I get this error related to laminas plugin
    Laminas\Http\Header\Exception\InvalidArgumentException: Invalid header value detected in C:\xampp\htdocs\magento242\vendor\laminas\laminas-http\src\Header\GenericHeader.php:54

I have no idea what's causing the error. any help?

1 Answers

Since others are facing the same problem, I circumvented (solved) the problem by avoiding to use Composer download and downloaded the zip file from Magento and problem was gone.

Related