How to re-enable Azure Postgresql Database User after too many failed login attempts

Viewed 816

After a password rotation for an Azure Postgresql Single Database user this error showed up in my Java application:

org.postgresql.util.PSQLException: FATAL: authentication failed for user "<username>": too many failed login attempts

How to re-enable this Database User?

EDIT: It seems time-sensitive, after waiting ~10 minutes the problem seems solved!

1 Answers

It seems time sensitive, after waiting ~10 minutes the problem is solved!

Two observations to help other people:

  • It's probably also IP related, as from other IP addresses the same user could connect perfectly fine (with the correct pwd :) ).
  • At the same time a different user (which was also rotated) was able to login from the same K8s cluster (same IP)
Related