Why do I still have to specify NEXT USED for my single-filegroup SQL Server Partition?

Viewed 416

I declared a Partition Scheme:

CREATE PARTITION SCHEME PartitionedValuationDatesScheme AS PARTITION PartitionedValuationDates ALL TO ([PRIMARY])

And I make and create Ranges:

ALTER PARTITION FUNCTION PartitionedValuationDates() SPLIT RANGE (5)
or
ALTER PARTITION FUNCTION PartitionedValuationDates() MERGE RANGE (79)

But I always have to declare NEXT USED after every change:

ALTER PARTITION SCHEME PartitionedValuationDatesScheme NEXT USED [PRIMARY]

otherwise the next range operation fails with:

Warning: The partition scheme 'PartitionedValuationDatesScheme' does not have any next used filegroup. Partition scheme has not been changed.

Why do I still need to do this, after defining the Scheme as ALL ON ([PRIMARY])? Shouldn't that make the NEXT USED unnecessary?

Am I doing something wrong? Or is just TheWayThingsAre?

0 Answers
Related