Linux Ubuntu 18. MariaDB 10.3. MariaDB service fails to start throwing a systemd error. The reason seems to be that the userid contains a dot (.).
systemd[1]: Invalid user/group name or numeric ID: myuser.withdot
Configuration:
The service file from MariaDB is /etc/systemd/system/mariadb.service.d/migrated.conf, and it contains:
[Service]
User=myuser.withdot