This problem occurs on some virtual machines under Windows Server 2012 or 2016. I can only run the 32-bit version although it is 64-bit OS. My DLL supposed to run on ISAPI-DLL mode (therefore called by IIS) also fails (Error 500). I suspected msolebdsql.dll (SQL Server ODBC driver) to be only 32-bit compatible on these machines, but it seems unlikely. I've been spending hours on looking for another feature that could be refused by Windows (invalid Windows API call ? There are very few, and it's very common ones). I failed. Can someone help ?