The solution for the error: "max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]" for docker-windows wsl2 is to type the commands:
wsl -d docker-desktop
sysctl -w vm.max_map_count=262144
The problem is that i need to execute it after every system restart....
why the setting removed after every restart? is the docker-desktop container builds again each time?
how can I make it permanent?
Other similar questions regarding linux and not Docker for Desktop on Windows 10 wsl.