Kubelet does not start when network plugin is calico

Viewed 1419

Trying to install an offline K8s HA cluster with kubespray. Installed all packages including calico and also docker images. But, it stacked at step kubernetes/master: Create kubeadm token for joining nodes with 24h expiration

After a little digging, saw that primary master node can not start kubelet with an error: Unable to update cni config: no networks found in /etc/cni/net.d and after a couple of line it start to say that kubelet nodes not sync.

I can not make it move forward.

Need help.

Regards.

0 Answers
Related