Deploy OpenStack with Kolla's all-in-one mode but failed while checking MariaDB port liveness

Viewed 637

The host IP in local network is 10.10.10.5 [A] and I set kolla_internal_vip_address to 10.10.10.105 [B]. However, the MariaDB service listen at B:3306 but kolla-ansible check port liveness with A:3306.

After executing "kolla-ansible -i ./all-in-one deploy"

Error info:

TASK [mariadb : Check MariaDB service port liveness] *******************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "elapsed": 10, "msg": "Timeout when waiting for search string MariaDB in 10.10.10.5:3306"}

Here is my globals.yml:

  kolla_base_distro: "ubuntu"
  kolla_install_type: "binary"
  network_interface: "enp0s8"
  neutron_external_interface: "enp0s3"
  kolla_internal_vip_address: "10.10.10.105"  # IP [B]
1 Answers

Add this option to your globals.yml

enable_mariadb_clustercheck: yes

It solved the problem in openstack xena and kolla-ansible 13.0.0.0rc1

Related