Use mulitple wildcard TLS certificates with single GCE loadbalancer

Viewed 15

I'm trying to use two TLS certificates for two wildcard domains on single GCE loadbalancer ingress object. But It is giving me error that certificates could not found and it stops working on 443.

Sample Code:

apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: loadbalancer
spec:
  tls:
  - secretName: "tls-secret-1"
  - secretName: "tls-secret-2"
  rules:
    - host: "*.domain1.com"
      http:
        paths:
        - path: /*
          backend:
            serviceName: fe-svc
            servicePort: 80
    - host: "*.domain2.com"
      http:
        paths:
        - path: /*
          backend:
            serviceName: fe2-svc
            servicePort: 80
        - path: /
          backend:
            serviceName: fe2-svc
            servicePort: 80

Here is the sample code. Can anyone please provide me solution of it?

Thanks.

0 Answers
Related