I'm troubleshooting YARN application failures that happen when nodes are LOST, so I'm trying to recreate this scenario. But I'm only able to force nodes to be SHUTDOWN instead of LOST. I'm using AWS EMR, and I've tried:
- logging into a node and doing a
shutdown -h now - logging into a node and doing
sudo stop hadoop-yarn-nodemanagerandsudo stop hadoop-hdfs-datanode - killing the NodeManager with a
kill -9 <pid>
Those result in SHUTDOWN nodes but not LOST nodes.
How do I create a LOST node in AWS EMR?