Private RDS Connection from Public Subnet Error : "Authentication plugin 'sha256_password'"

Viewed 900

I have a RDS in private subnet and and ec2 in public subnet, both subnet are in same availability zone, RDS security group has access from entire VPC CIDR on all 0-65535 ports

When I try to ssh into RDS from my public ec2 using command :

mysql -h <endpointurl> -P 3306 -u admin -p

I get following error:

ERROR 2059 (HY000): Authentication plugin 'sha256_password' cannot be loaded: /usr/lib64/mysql/plugin/sha256_password.so: cannot open shared object file: No such file or directory.

whats wrong here , please help

1 Answers

solved it , it might help you

when creating RDS choose mysql version 5.x.x instead of 8.x.x. MySQL client for EC2 is not able to connect to version 8.x.x.

enter image description here

Related