minikube failed to start

Viewed 5303

Hello so i was using yesterday minikube and it was working fine but today i was trying to start with minikube start command and it give the following errors :minikube start

and after running minikube status it give the following result :minikube status

Thanks in advance for any help.

1 Answers

You are getting the following error:

Exiting due to GUEST_START: Failed kubeconfig update: could not read config: Error decoding config from data control character are not allowed

and

getting k8s client: client config: error loading config file "C:\Users<Your User>/.kube/config control characters are not allowed

Those errors indicates that your $KUBECONFIG has an invalid character in it.

Troubleshooting

For the future use, please provide more detailed information. It's well described in Minikube Troubleshooting. The following commands might provide useful information for troubleshooting:

$ minikube logs
$ minikube start --alsologtostderr -v=2
$ kubectl config view

In minikube output there is also updating the running virtualbox "minikube" VM It might be related with network changes.

Possible Solution

  • Remove config file from C:\Users\<Your User>/.kube/ and start minikube again.
  • Update your Minikube to newest version (current is 1.16).
  • Recreate your minikube cluster using minikube delete and create new one.
  • Execite minikube update context.
Related